PC Financial
Incident Report for Inverite Insights
Resolved
Affected Service: IBV – Inverite Bank Verification

Affected Bank: PC Financial

The issue impacting PC Financial has been resolved, and all systems are now functioning normally. We apologize for any inconvenience this may have caused and appreciate your patience throughout the resolution process.
Posted Feb 28, 2024 - 09:33 PST
Identified
Affected Service: IBV – Inverite Bank Verification

Affected Bank: PC Financial

We have identified the issue impacting PC Financial and are actively working on implementing a solution. Our team is dedicated to resolving this as quickly as possible. Thank you for your continued patience and understanding.
Posted Feb 27, 2024 - 09:52 PST
Investigating
Affected Service: IBV – Inverite Bank Verification

Affected Bank: PC Financial

We are aware of an issue impacting PC Financial and are actively investigating. Our team is working diligently to identify the root cause and implement a resolution. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Feb 26, 2024 - 13:57 PST
This incident affected: PC Financial.