Simplii

Incident Report for Inverite Insights

Resolved

The issue impacting Simplii has been resolved, and all systems are now functioning normally.
Posted Aug 01, 2025 - 17:45 PDT

Monitoring

Simplii has fixed their Online Banking issue. We are now actively monitoring their implemented fix to ensure that restoration efforts are completed successfully.
Posted Aug 01, 2025 - 11:24 PDT

Identified

We have identified that the issue is due to Simplii Online Banking currently being down. We will continue to monitor the situation and provide an update as soon as Simplii implements a fix.
Posted Aug 01, 2025 - 09:13 PDT

Investigating

We are aware of an issue impacting Simplii and are actively investigating. Our team is working diligently to identify the root cause and implement a resolution. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Aug 01, 2025 - 09:12 PDT
This incident affected: Simplii.