TD

Incident Report for Inverite Insights

Resolved

The service disruption on TD's end has been resolved, and all systems are now functioning normally. We apologize for any inconvenience this may have caused and appreciate your patience throughout the resolution process.
Posted Mar 13, 2026 - 10:05 PDT

Monitoring

We are actively monitoring TD to ensure that the service disruption on their end has been resolved. During this monitoring phase, we are closely observing system behavior to verify that all functionalities are fully restored.
Posted Mar 13, 2026 - 09:35 PDT

Investigating

TD is currently experiencing an issue with their system and are actively investigating. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Mar 13, 2026 - 09:13 PDT
This incident affected: TD.